DirSync Installation Error PowerShell

sync

The minimum Version of Windows PowerShell required is 2,0. Please install the minimum Version required (or higher) and try again.

DirSyncInstallError

Today I was installing DirSync for a customer With a brand New Windows Server 2021 R2, which includes PowerShell 2,0 and 4,0. So I can’t install any better Version of PowerShell, but it keeps telling me that PowerShell isn’t installed. But ofcourse it is, so that isn’t realy the problem.

The problem is that DirSync can’t find any PowerShell Versions installed on my Server, and I am living in Norway, so we change the regional settings to Norwegian (BokmÃ¥l). This makes PowerShell named With 2,0 instead of 2.0, and DirSync will look for 2.0 or newer With a dot instead of comma seperating the numbers.

The workaround is then to change the Regional settings by opening Region in the Control Panel. Then log off and back on before you install DirSync.

DirSyncRegionalSettings

Leave a Comment